summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb b/meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb
new file mode 100644
index 000000000..7bc3cffdd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_2.9.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "JSON Web Token implementation in Python"
2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
7
8SRC_URI[sha256sum] = "7e1e5b56cc735432a7369cbfa0efe50fa113ebecdc04ae6922deba8b84582d0c"
9
10PYPI_PACKAGE = "pyjwt"
11inherit pypi python_setuptools_build_meta
12
13RDEPENDS:${PN} = "\
14 python3-cryptography \
15 python3-json \
16"
17
18BBCLASSEXTEND = "native nativesdk"