summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb24
1 files changed, 21 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
index a20eafec4..78a1ef2ac 100644
--- a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
@@ -1,7 +1,23 @@
1inherit distutils3 1DESCRIPTION = "Cryptographic modules for Python."
2require python-pycrypto.inc 2HOMEPAGE = "http://www.pycrypto.org/"
3LICENSE = "PSFv2"
4LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
3 5
4SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch" 6DEPENDS += " gmp"
7
8export HOST_SYS
9
10inherit pypi autotools-brokensep distutils3
11
12SRC_URI += "file://cross-compiling.patch \
13 file://CVE-2013-7459.patch \
14 file://0001-Replace-time.clock-with-time.process_time.patch \
15 "
16
17SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
18SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
19
20do_compile[noexec] = "1"
5 21
6# We explicitly call distutils_do_install, since we want it to run, but 22# We explicitly call distutils_do_install, since we want it to run, but
7# *don't* want the autotools install to run, since this package doesn't 23# *don't* want the autotools install to run, since this package doesn't
@@ -9,3 +25,5 @@ SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch"
9do_install() { 25do_install() {
10 distutils3_do_install 26 distutils3_do_install
11} 27}
28
29BBCLASSEXTEND = "native nativesdk"