summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb
new file mode 100644
index 000000000..dee4bf6eb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pychromecast_14.0.1.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
2HOMEPAGE = "https://github.com/balloob/pychromecast"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
5
6SRC_URI += "file://0001-Allow-newer-version-of-wheel-and-setuptools.patch"
7SRC_URI[sha256sum] = "e16e0a7f9488319191b8b4fa21ca0beb4bf12eeda5c9bf640241188f2bea0a3e"
8
9PYPI_PACKAGE = "PyChromecast"
10
11inherit pypi python_setuptools_build_meta
12
13RDEPENDS:${PN} += "\
14 python3-zeroconf (>=0.131.0) \
15 python3-protobuf (>=4.25.2) \
16 python3-casttube (>=0.2.1) \
17"