diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-path_16.9.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-path_16.9.0.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-path_16.9.0.bb b/meta-python/recipes-devtools/python/python3-path_16.9.0.bb new file mode 100644 index 000000000..19bf11b6c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-path_16.9.0.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "A module wrapper for os.path" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f" | ||
4 | |||
5 | SRC_URI[sha256sum] = "dfd31c2af60e8889a13538bef302ade7adacdb5351836be22638e2349ddd5d7b" | ||
6 | |||
7 | SRC_URI += "\ | ||
8 | file://run-ptest \ | ||
9 | " | ||
10 | |||
11 | inherit pypi python_setuptools_build_meta ptest | ||
12 | |||
13 | DEPENDS += "python3-setuptools-scm-native" | ||
14 | |||
15 | RDEPENDS:${PN} += " \ | ||
16 | python3-appdirs \ | ||
17 | python3-crypt \ | ||
18 | python3-io \ | ||
19 | python3-numbers \ | ||
20 | python3-shell \ | ||
21 | " | ||
22 | RDEPENDS:${PN}-ptest += " \ | ||
23 | python3-pytest \ | ||
24 | python3-unittest-automake-output \ | ||
25 | " | ||
26 | |||
27 | BBCLASSEXTEND = "nativesdk native" | ||
28 | |||
29 | do_install_ptest() { | ||
30 | install -d ${D}${PTEST_PATH}/test | ||
31 | cp -rf ${S}/test_* ${D}${PTEST_PATH}/test/ | ||
32 | install -d ${D}${PTEST_PATH}/path | ||
33 | cp -rf ${S}/path/* ${D}${PTEST_PATH}/path/ | ||
34 | } | ||