summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb b/meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb
new file mode 100644
index 000000000..25e382088
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nmap_1.9.1.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "python-nmap is a python library which helps in using nmap port scanner"
2HOMEPAGE = "https://www.nmmapper.com/"
3SECTION = "devel/python"
4LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
6
7DEPENDS += "python3-wheel-native"
8
9PYPI_PACKAGE = "python3-nmap"
10
11SRC_URI[sha256sum] = "8465cfb013f5cdfa8a1050c40cdae600b581ee32f1864ec404927aee49b4262c"
12
13inherit pypi setuptools3
14
15RDEPENDS:${PN} += "nmap \
16 python3-requests \
17 python3-simplejson \
18"