summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb
new file mode 100644
index 000000000..eac069f04
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.60.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
2keyboard, territory"
3HOMEPAGE = "https://github.com/mike-fabian/langtable/"
4LICENSE = "GPL-3.0-or-later"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI[sha256sum] = "ae77d62fe6002308ce6197310c4a933c4e13632bbaf7219a3533dc45d36223f8"
10
11inherit pypi setuptools3 python3native
12
13DISTUTILS_INSTALL_ARGS += " \
14 --install-data=${datadir}/langtable"
15
16FILES:${PN} += "${datadir}/*"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-doctest \
21 ${PYTHON_PN}-logging \
22 ${PYTHON_PN}-xml \
23"