summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb b/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
new file mode 100644
index 000000000..23060f3d6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_8.24.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
5
6PYPI_PACKAGE = "ipython"
7
8SRC_URI[sha256sum] = "010db3f8a728a578bb641fdd06c063b9fb8e96a9464c63aec6310fbcb5e80501"
9
10RDEPENDS:${PN} = "\
11 python3-setuptools \
12 python3-jedi \
13 python3-decorator \
14 python3-pickleshare \
15 python3-traitlets \
16 python3-prompt-toolkit \
17 python3-pygments \
18 python3-backcall \
19 python3-pydoc \
20 python3-debugger \
21 python3-pexpect \
22 python3-unixadmin \
23 python3-misc \
24 python3-sqlite3 \
25 python3-stack-data \
26"
27
28inherit setuptools3 pypi