summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-inotify_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-inotify_git.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-inotify_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inotify_git.bb b/meta-python/recipes-devtools/python/python3-inotify_git.bb
new file mode 100644
index 000000000..15fb92eed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inotify_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
2AUTHOR = "Dustin Oprea"
3HOMEPAGE = "https://pypi.org/project/inotify/"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
6
7SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
8
9SRC_URI = " \
10 git://github.com/dsoprea/pyinotify.git;branch=master;protocol=https \
11 file://run-ptest \
12"
13
14SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
15
16S = "${WORKDIR}/git"
17
18inherit setuptools3 ptest
19PIP_INSTALL_PACKAGE = "inotify"
20PIP_INSTALL_DIST_PATH = "${S}/dist"
21
22
23RDEPENDS:${PN} += " \
24 python3-ctypes \
25 python3-logging \
26"
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests
34 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
35}