summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb
new file mode 100644
index 000000000..45098e662
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth_2.27.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6inherit pypi setuptools3
7
8SRC_URI[sha256sum] = "e863a56ccc2d8efa83df7a80272601e43487fa9a728a376205c86c26aaefa821"
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-asyncio \
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-logging \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-numbers \
18"
19
20RDEPENDS:${PN} += "\
21 ${PYTHON_PN}-aiohttp \
22 ${PYTHON_PN}-cachetools \
23 ${PYTHON_PN}-pyasn1-modules \
24 ${PYTHON_PN}-rsa \
25 ${PYTHON_PN}-six \
26"