summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb b/meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb
index ffc4aa7fd..e5fc54136 100644
--- a/meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-socketio_4.2.1.bb
@@ -1,2 +1,18 @@
1inherit setuptools3 1SUMMARY = "Socket.IO integration for Flask applications"
2require python-flask-socketio.inc 2HOMEPAGE = "https://github.com/miguelgrinberg/Flask-SocketIO/"
3SECTION = "devel/python"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "Flask-SocketIO"
11
12SRC_URI[md5sum] = "b23222fb7dd2f0676d78bbe24153fd80"
13SRC_URI[sha256sum] = "2172dff1e42415ba480cee02c30c2fc833671ff326f1598ee3d69aa02cf768ec"
14
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-flask \
17 ${PYTHON_PN}-socketio \
18 "