summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
index ec16e8884..a7b156535 100644
--- a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
@@ -6,13 +6,22 @@ HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8 8
9DEPENDS += "python3-pip-native"
10
11SRC_URI += "file://run-ptest \
12 "
9SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" 13SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
10 14
11DEPENDS += "python3-pip-native" 15inherit ptest pypi setuptools3
12 16
13inherit pypi setuptools3 17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
20}
14 21
15PACKAGECONFIG[testing] = ",,,python3-pre-commit" 22RDEPENDS_${PN}-ptest += "\
23 python3-pytest \
24"
16 25
17RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" 26RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
18 27