summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb b/meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb
new file mode 100644
index 000000000..937d96860
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-elementpath_4.5.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Provide XPath 1.0 and 2.0 selectors for Python's ElementTree XML data structures, both for the standard ElementTree library and for the lxml.etree library."
2HOMEPAGE = "https://github.com/sissaschool/elementpath"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5dbb7fb7d72da3921202dd7b995d3ecf"
5
6SRC_URI[sha256sum] = "affdc8de95af1a4c10d1d2ed79c6fa56b59c26c7fce64b73497569e9dea46998"
7
8PYPI_PACKAGE = "elementpath"
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-xml \
13 python3-core \
14 python3-numbers \
15 python3-datetime \
16 python3-stringold \
17"
18
19BBCLASSEXTEND = "native nativesdk"