summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb27
1 files changed, 23 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
index 5b4f7eb93..8e967f925 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
@@ -6,12 +6,31 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
6PYPI_PACKAGE = "ecdsa" 6PYPI_PACKAGE = "ecdsa"
7SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8" 7SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8"
8 8
9inherit pypi setuptools3 python3native 9inherit pypi setuptools3 python3native ptest
10 10
11RDEPENDS:${PN} += "python3-six python3-gmpy2" 11SRC_URI += " \
12 file://run-ptest \
13"
12 14
13BBCLASSEXTEND = "native nativesdk" 15RDEPENDS:${PN}-ptest += " \
16 python3-hypothesis \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/src/ecdsa/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN} += " \
27 python3-gmpy2 \
28 python3-json \
29 python3-six \
30"
14 31
15do_install:append() { 32do_install:append() {
16 rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py 33 rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py
17} 34}
35
36BBCLASSEXTEND = "native nativesdk"