summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dt-schema_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dt-schema_git.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dt-schema_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dt-schema_git.bb b/meta-python/recipes-devtools/python/python3-dt-schema_git.bb
new file mode 100644
index 000000000..06a9012ca
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dt-schema_git.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Tooling for devicetree validation using YAML and jsonschema"
2AUTHOR = "Rob Herring"
3
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=2;endline=3;md5=c795d4924c5f739424fa8d9b569c6659"
6
7inherit setuptools3
8
9SRC_URI = "git://github.com/robherring/dt-schema.git"
10SRCREV = "5009e47c1c76e48871f5988e08dad61f3c91196b"
11PV = "0.1+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS_${PN} = "python3-jsonschema python3-ruamel-yaml"