summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-distro_1.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-distro_1.7.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
new file mode 100644
index 000000000..f069234d1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Distro is an OS platform information API"
2SECTION = "devel/python"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
5
6PYPI_PACKAGE = "distro"
7
8SRC_URI[sha256sum] = "151aeccf60c216402932b52e40ee477a939f8d58898927378a02abbe852c1c39"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-logging \
16 ${PYTHON_PN}-shell \
17"
18
19BBCLASSEXTEND = "native nativesdk"