summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
new file mode 100644
index 000000000..a68a736a8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Extensions to the standard Python datetime module"
2DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library."
3HOMEPAGE = "https://dateutil.readthedocs.org"
4LICENSE = "BSD-3-Clause & Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
6
7SRC_URI[sha256sum] = "0123cacc1627ae19ddf3c27a5de5bd67ee4586fbdd6440d9748f8abb483d3e86"
8
9PYPI_PACKAGE = "python-dateutil"
10inherit pypi setuptools3
11
12PACKAGES =+ "${PN}-zoneinfo"
13FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
14
15DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-numbers \
20 ${PYTHON_PN}-six \
21 ${PYTHON_PN}-stringold \
22"
23
24BBCLASSEXTEND = "native nativesdk"