summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb b/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
new file mode 100644
index 000000000..fa28861e9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Security oriented static analyser for python code."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
4
5SRC_URI[md5sum] = "c6a6772d7afa0af8828b3384e73b7085"
6SRC_URI[sha256sum] = "41e75315853507aa145d62a78a2a6c5e3240fe14ee7c601459d0df9418196065"
7
8DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
9
10inherit setuptools3 pypi
11
12RDEPENDS_${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
13
14BBCLASSEXTEND = "native"