summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-tornado_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-tornado_4.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.2.1.bb b/meta-python/recipes-devtools/python/python-tornado_4.2.1.bb
new file mode 100644
index 000000000..4580b3462
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado_4.2.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=c7dc99d243c4004087229f84f6b46828"
9
10SRCNAME = "tornado"
11
12SRC_URI = " \
13 https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
14"
15SRC_URI[md5sum] = "d523204389cfb70121bb69709f551b20"
16SRC_URI[sha256sum] = "a16fcdc4f76b184cb82f4f9eaeeacef6113b524b26a2cb331222e4a7fa6f2969"
17
18inherit setuptools
19
20RDEPENDS_${PN} += "python-compression python-numbers python-email python-subprocess \
21 python-pkgutil python-html python-json python-backports-ssl python-certifi"
22
23RDEPENDS_${PN}-test += "${PN} python-unittest"
24
25S = "${WORKDIR}/${SRCNAME}-${PV}"
26
27PACKAGES =+ "\
28 ${PN}-test \
29"
30
31FILES_${PN}-test = " \
32 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
33 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
34"