summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb22
1 files changed, 4 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb
index b0a1acb48..32573b7a0 100644
--- a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb
+++ b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb
@@ -1,22 +1,8 @@
1SUMMARY = "A libudev binding" 1require python-pyudev.inc
2LICENSE = "LGPLv2.1+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
4
5SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b"
6SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b"
7
8inherit pypi setuptools
9
10do_configure_prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14 2
15RDEPENDS_${PN} = "\ 3RDEPENDS_${PN} = "\
16 ${PYTHON_PN}-contextlib \ 4 ${PYTHON_PN}-contextlib \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-misc \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-subprocess \
21 ${PYTHON_PN}-threading \
22" 5"
6
7inherit pypi setuptools
8