summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
deleted file mode 100644
index 133e66da4..000000000
--- a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://README.txt;md5=83c5bf8b16a5f99507f2f47a21ae3b81"
5PR = "r1"
6
7DEPENDS += "python-numpy freetype libpng python-dateutil python-pytz"
8RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng python-dateutil python-pytz"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \
11 file://fix_setup.patch \
12 file://fix_setupext.patch \
13"
14
15S = "${WORKDIR}/matplotlib-${PV}"
16
17EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
18
19inherit distutils
20
21do_compile_prepend() {
22 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
23 true
24}
25
26# need to export these variables for python-config to work
27export PYTHONPATH
28export STAGING_INCDIR
29export STAGING_LIBDIR
30
31
32SRC_URI[md5sum] = "57a627f30b3b27821f808659889514c2"
33SRC_URI[sha256sum] = "be37e1d86c65ecacae6683f8805e051e9904e5f2e02bf2b7a34262c46a6d06a7"