summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
deleted file mode 100644
index a3f9a09c6..000000000
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
3
4DEPENDS = "openssl swig-native python"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
8
9SRC_URI = " \
10 file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
11 file://0001-M2Crypto-Error-fix.patch"
12
13SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17"
14SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a"
15
16PYPI_PACKAGE = "M2Crypto"
17inherit pypi setuptools
18
19SWIG_FEATURES_x86-64 = "-D__x86_64__"
20SWIG_FEATURES ?= ""
21export SWIG_FEATURES
22
23# Get around a problem with swig, but only if the
24# multilib header file exists.
25#
26do_compile_prepend() {
27 if [ "${SITEINFO_BITS}" = "64" ];then
28 bit="64"
29 else
30 bit="32"
31 fi
32
33 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
34 for i in SWIG/_ec.i SWIG/_evp.i; do
35 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
36 done
37 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
38 for i in SWIG/_ec.i SWIG/_evp.i; do
39 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
40 done
41 fi
42}
43
44BBCLASSEXTEND = "native"