diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb new file mode 100644 index 000000000..67ec9214a --- /dev/null +++ b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "A Python crypto and SSL toolkit" | ||
2 | HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto" | ||
3 | |||
4 | DEPENDS = "openssl swig-native python" | ||
5 | |||
6 | LICENSE = "BSD" | ||
7 | LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e" | ||
8 | |||
9 | SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz \ | ||
10 | file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch" | ||
11 | |||
12 | SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17" | ||
13 | SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a" | ||
14 | |||
15 | S = "${WORKDIR}/M2Crypto-${PV}" | ||
16 | |||
17 | inherit setuptools | ||
18 | |||
19 | SWIG_FEATURES_x86-64 = "-D__x86_64__" | ||
20 | SWIG_FEATURES ?= "" | ||
21 | export SWIG_FEATURES | ||
22 | |||
23 | # Get around a problem with swig, but only if the | ||
24 | # multilib header file exists. | ||
25 | # | ||
26 | do_compile_prepend() { | ||
27 | if [ "${SITEINFO_BITS}" = "64" ];then | ||
28 | bit="64" | ||
29 | else | ||
30 | bit="32" | ||
31 | fi | ||
32 | |||
33 | if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then | ||
34 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
35 | sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i" | ||
36 | done | ||
37 | elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then | ||
38 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
39 | sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i" | ||
40 | done | ||
41 | fi | ||
42 | } | ||
43 | |||
44 | BBCLASSEXTEND = "native" | ||