summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-ldap_2.4.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-ldap_2.4.32.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-ldap_2.4.32.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-ldap_2.4.32.bb b/meta-python/recipes-devtools/python/python-ldap_2.4.32.bb
new file mode 100644
index 000000000..f25ad1eda
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ldap_2.4.32.bb
@@ -0,0 +1,29 @@
1#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a wrapper in Python to LDAP"
5DESCRIPTION = "This module provides access to the LDAP \
6(Lightweight Directory Access Protocol) through Python operations \
7instead of C API. The module mainly acts as a wrapper for the \
8OpenLDAP 2.x libraries. Errors will appear as exceptions."
9
10LICENSE = "PSF"
11HOMEPAGE = "http://www.python-ldap.org/"
12DEPENDS = "python openldap cyrus-sasl"
13
14PYPI_PACKAGE = "python-ldap"
15inherit pypi setuptools
16
17LIC_FILES_CHKSUM = "file://LICENCE;md5=a41c82edffa04912007cae1d20cac555"
18SRC_URI[md5sum] = "7c46c8a04acc227a778c7900c87cdfc7"
19SRC_URI[sha256sum] = "5810f1b5a9ae9255df99fb9c2dcab7352fed325687efda56c0faae1a82c5e3cb"
20
21do_configure_prepend() {
22 sed -i -e 's:^library_dirs =.*::' setup.cfg
23 sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
24}
25
26RDEPENDS_${PN} = " \
27 ${PYTHON_PN}-pprint \
28 ${PYTHON_PN}-threading \
29"