summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb
new file mode 100644
index 000000000..7155f42c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.6.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
8 "
9RDEPENDS_${PN} = "python-enum34 \
10 python-futures \
11 python-protobuf \
12 python-setuptools \
13 python-six \
14"
15
16LICENSE = "BSD-3-Clause"
17LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
18
19inherit pypi setuptools
20
21SRC_URI[md5sum] = "c91b8c105ff4163b41790f3b63db92e1"
22SRC_URI[sha256sum] = "6cd793d515ec53587a8968f2a53647f1449763ad06be0d287e3c1e47418e1e50"
23
24# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
25BBCLASSEXTEND = "native"