summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb b/meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb
new file mode 100644
index 000000000..ef108485a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flufl-enum_4.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A Python enumeration package."
2DESCRIPTION = "The flufl.enum library is a Python enumeration package. Its goal is to provide simple, \
3specific, concise semantics in an easy to read and write syntax. flufl.enum has just enough of the \
4features needed to make enumerations useful, but without a lot of extra baggage to weigh them down. "
5
6LICENSE = "LGPLv3"
7LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=250adb4c74c359b7049abcd9d6b115e7"
8
9SRC_URI[md5sum] = "461779384c07ed2b5f554a5d51a000c4"
10SRC_URI[sha256sum] = "94da1413ba085473652f81565847913ea1543d1739972ecbd6afe57d7b1b68b4"
11
12PYPI_PACKAGE = "flufl.enum"
13inherit pypi setuptools
14
15PACKAGES =+ "\
16 ${PN}-test \
17"
18
19FILES_${PN}-doc += "\
20 ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/*.rst \
21 ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/docs \
22"
23
24FILES_${PN}-test += "${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/tests"