diff options
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r-- | meta-python/recipes-connectivity/python-mprpc/files/0001-fix_setup_py.patch | 34 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb | 17 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-mprpc/files/0001-fix_setup_py.patch b/meta-python/recipes-connectivity/python-mprpc/files/0001-fix_setup_py.patch new file mode 100644 index 000000000..f5df9b9ee --- /dev/null +++ b/meta-python/recipes-connectivity/python-mprpc/files/0001-fix_setup_py.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From bda99eab9036d46e7bb06b446d11cab0b1dd8093 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrej Rode <andrej.rode@ettus.com> | ||
3 | Date: Mon, 10 Apr 2017 16:49:50 -0700 | ||
4 | Subject: [PATCH] setup: remove find_packages and only install mprpc | ||
5 | |||
6 | Signed-off-by: Andrej Rode <andrej.rode@ettus.com> | ||
7 | --- | ||
8 | setup.py | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/setup.py b/setup.py | ||
12 | index 5001d0c..4c0ba75 100644 | ||
13 | --- a/setup.py | ||
14 | +++ b/setup.py | ||
15 | @@ -1,6 +1,6 @@ | ||
16 | # -*- coding: utf-8 -*- | ||
17 | |||
18 | -from setuptools import setup, Extension, find_packages | ||
19 | +from setuptools import setup, Extension | ||
20 | |||
21 | setup( | ||
22 | name='mprpc', | ||
23 | @@ -10,7 +10,7 @@ setup( | ||
24 | author='Studio Ousia', | ||
25 | author_email='ikuya@ousia.jp', | ||
26 | url='http://github.com/studio-ousia/mprpc', | ||
27 | - packages=find_packages(), | ||
28 | + packages=['mprpc'], | ||
29 | ext_modules=[ | ||
30 | Extension('mprpc.client', ['mprpc/client.c']), | ||
31 | Extension('mprpc.server', ['mprpc/server.c']) | ||
32 | -- | ||
33 | 2.10.2 | ||
34 | |||
diff --git a/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb new file mode 100644 index 000000000..78df00af2 --- /dev/null +++ b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "A gevent based messagpack rpc library" | ||
2 | DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \ | ||
3 | It is based on gevent for handling connections and enabling concurrent connections." | ||
4 | HOMEPAGE = "https://github.com/studio-ousia/mprpc" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859" | ||
7 | DEPENDS += "python-gevent" | ||
8 | RDEPENDS_${PN} += "python-gevent python-msgpack python-gsocketpool" | ||
9 | |||
10 | SRC_URI_append = " \ | ||
11 | file://0001-fix_setup_py.patch;patch=1;pnum=1 \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee" | ||
15 | SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82" | ||
16 | |||
17 | inherit pypi setuptools | ||