summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb
new file mode 100644
index 000000000..21be04720
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Guess OpenSSL include path"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
7
8SRC_URI[md5sum] = "e768fe2c07826b0ac9ea604c79f93032"
9SRC_URI[sha256sum] = "aa6b18e38cb852cbad80a58cd90c395b40819d4d01e0ab37e7703149094d7167"
10
11DEPENDS += "openssl"
12
13RDEPENDS_${PN}="perl-module-config perl-module-exporter perl-module-symbol perl-module-file-spec"
14
15EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
16
17S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
18
19inherit cpan
20
21BBCLASSEXTEND = "native"