diff options
Diffstat (limited to 'meta-perl/recipes-perl')
-rw-r--r-- | meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch | 33 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb | 8 |
2 files changed, 38 insertions, 3 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch new file mode 100644 index 000000000..6efa7d8f9 --- /dev/null +++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | --- a/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2018-08-27 14:56:24.788544991 +0200 | ||
2 | +++ b/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2018-08-27 15:00:12.847266331 +0200 | ||
3 | @@ -24,20 +24,7 @@ | ||
4 | $self->requires_external_cc; | ||
5 | |||
6 | my $prefix = $self->find_openssl_prefix; | ||
7 | - my $exec = $self->find_openssl_exec($prefix); | ||
8 | - | ||
9 | - unless (-x $exec) { | ||
10 | - print <<EOM; | ||
11 | -*** Could not find OpenSSL | ||
12 | - If it's already installed, please set the OPENSSL_PREFIX environment | ||
13 | - variable accordingly. If it isn't installed yet, get the latest version | ||
14 | - from http://www.openssl.org/. | ||
15 | -EOM | ||
16 | - exit 0; # according http://wiki.cpantesters.org/wiki/CPANAuthorNotes this is best-practice when "missing library" | ||
17 | - } | ||
18 | - | ||
19 | - $self->check_openssl_version($prefix, $exec); | ||
20 | - my $opts = $self->ssleay_get_build_opts($prefix, $exec); | ||
21 | + my $opts = $self->ssleay_get_build_opts($prefix); | ||
22 | |||
23 | $self->makemaker_args( | ||
24 | CCCDLFLAGS => $opts->{cccdlflags}, | ||
25 | @@ -58,7 +45,7 @@ | ||
26 | } | ||
27 | |||
28 | sub ssleay_get_build_opts { | ||
29 | - my ($self, $prefix, $exec) = @_; | ||
30 | + my ($self, $prefix) = @_; | ||
31 | |||
32 | my $opts = { | ||
33 | lib_links => [], | ||
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb index a0bb90e7d..dccef1640 100644 --- a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb +++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb | |||
@@ -23,6 +23,7 @@ RDEPENDS_${PN} += "\ | |||
23 | " | 23 | " |
24 | 24 | ||
25 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \ | 25 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \ |
26 | file://no-exec-on-configure.patch \ | ||
26 | file://run-ptest \ | 27 | file://run-ptest \ |
27 | " | 28 | " |
28 | SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69" | 29 | SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69" |
@@ -32,9 +33,10 @@ S = "${WORKDIR}/Net-SSLeay-${PV}" | |||
32 | 33 | ||
33 | inherit cpan ptest | 34 | inherit cpan ptest |
34 | 35 | ||
35 | export OPENSSL_PREFIX="${STAGING_LIBDIR}" | 36 | do_configure() { |
36 | 37 | export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}" | |
37 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS='-L${STAGING_LIBDIR} -lcrypto -lssl -L${STAGING_BASELIBDIR} -lz'" | 38 | cpan_do_configure |
39 | } | ||
38 | 40 | ||
39 | do_install_ptest() { | 41 | do_install_ptest() { |
40 | cp -r ${B}/t ${D}${PTEST_PATH} | 42 | cp -r ${B}/t ${D}${PTEST_PATH} |