summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libtext
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libtext')
-rw-r--r--meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb27
-rw-r--r--meta-perl/recipes-perl/libtext/libtext-iconv-perl_1.7.bb24
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
new file mode 100644
index 000000000..a4c246e34
--- /dev/null
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Text::Diff - Perform diffs on files and record sets"
2DESCRIPTION = "diff() provides a basic set of services akin to the GNU diff \
3utility. It is not anywhere near as feature complete as GNU diff, but it is \
4better integrated with Perl and available on all platforms. It is often \
5faster than shelling out to a system's diff executable for small files, \
6and generally slower on larger files."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
10
11LICENSE = "Artistic-1.0 | GPL-2.0+"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz"
15SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
16SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
17
18S = "${WORKDIR}/Text-Diff-${PV}"
19
20inherit cpan
21
22RDEPENDS_${PN} = " libalgorithm-diff-perl \
23 perl-module-extutils-makemaker \
24 perl-module-exporter \
25"
26
27BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libtext/libtext-iconv-perl_1.7.bb b/meta-perl/recipes-perl/libtext/libtext-iconv-perl_1.7.bb
new file mode 100644
index 000000000..934be0399
--- /dev/null
+++ b/meta-perl/recipes-perl/libtext/libtext-iconv-perl_1.7.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Perl interface to iconv() codeset conversion function"
2DESCRIPTION = "\
3The Text::Iconv module provides a Perl interface to the iconv() \
4function as defined by the Single UNIX Specification. The convert() \
5method converts the encoding of characters in the input string from \
6the fromcode codeset to the tocode codeset, and returns the result. \
7Settings of fromcode and tocode and their permitted combinations are \
8implementation-dependent. Valid values are specified in the system \
9documentation."
10SECTION = "libs"
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=3;endline=6;md5=fadf2919c7128e887d26b4d905f90649"
13RRECOMMENDS_${PN} += "glibc-gconvs"
14
15SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MP/MPIOTR/Text-Iconv-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "81b26e069eaebb084e91ea3c009b67ae"
18SRC_URI[sha256sum] = "5b80b7d5e709d34393bcba88971864a17b44a5bf0f9e4bcee383d029e7d2d5c3"
19
20S = "${WORKDIR}/Text-Iconv-${PV}"
21
22inherit cpan
23
24FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Text/Iconv/.debug/"