summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb')
-rw-r--r--meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb
new file mode 100644
index 000000000..cc1ac6ed5
--- /dev/null
+++ b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Term::ReadKey - A perl module for simple terminal control."
2DESCRIPTION = "Term::ReadKey is a compiled perl module dedicated to providing simple \
3control over terminal driver modes (cbreak, raw, cooked, etc.,) support \
4for non-blocking reads, if the architecture allows, and some generalized \
5handy functions for working with terminals. One of the main goals is to \
6have the functions as portable as possible, so you can just plug in 'use \
7Term::ReadKey' on any architecture and have a good likelihood of it \
8working."
9HOMEPAGE = "http://search.cpan.org/~jstowe/TermReadKey-${PV}"
10SECTION = "libraries"
11
12LICENSE = "Artistic-1.0 | GPLv1+"
13LIC_FILES_CHKSUM = "file://README;md5=c275db663c8489a5709ebb22b185add5"
14
15SRC_URI = "${CPAN_MIRROR}/authors/id/J/JS/JSTOWE/TermReadKey-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "b2b4aab7a0e6bddb7ac3b21ba637482c"
18SRC_URI[sha256sum] = "5a645878dc570ac33661581fbb090ff24ebce17d43ea53fd22e105a856a47290"
19
20S = "${WORKDIR}/TermReadKey-${PV}"
21
22UPSTREAM_CHECK_URI = "https://metacpan.org/release/TermReadKey"
23UPSTREAM_CHECK_REGEX = "TermReadKey\-(?P<pver>(\d+\.\d+))(?!_\d+)\.tar.gz"
24
25# It needs depend on native to let dynamic loader use native modules
26# rather than target ones.
27DEPENDS = "libterm-readkey-perl-native"
28
29inherit cpan ptest-perl
30
31RDEPENDS_${PN}-ptest += " \
32 perl-module-test-more \
33"
34
35do_configure_append () {
36 # Hack the dynamic module loader so that it use native modules since it can't load
37 # the target ones.
38 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
39 sed -i -e "s#-I\$(INST_ARCHLIB)#-I${STAGING_BINDIR_NATIVE}/perl-native/perl/vendor_perl/${@get_perl_version(d)}#g" Makefile
40 fi
41}
42
43BBCLASSEXTEND = "native"