summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
new file mode 100644
index 000000000..32d92ba65
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
2DESCRIPTION = "This module offers some high level convenience functions for accessing \
3web pages on SSL servers (for symmetry, same API is offered for \
4accessing http servers, too), a sslcat() function for writing your own \
5clients, and finally access to the SSL api of SSLeay/OpenSSL package \
6so you can write servers or clients for more complicated applications."
7HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
8SECTION = "libs"
9
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
12
13DEPENDS = "openssl zlib"
14RDEPENDS_${PN} += "perl-module-carp \
15 perl-module-errno \
16 perl-module-extutils-makemaker \
17 perl-module-mime-base64 \
18 perl-module-socket \
19 "
20
21SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
22 file://run-ptest \
23 "
24SRC_URI[md5sum] = "b1e0fd96d7f3be57580377226ca5f089"
25SRC_URI[sha256sum] = "a541a66d59fc5f9bb7af09d3a0b68305e4c43ba9488b12915728fd282ea01b93"
26
27S = "${WORKDIR}/Net-SSLeay-${PV}"
28
29inherit cpan ptest
30
31EXTRA_CPANFLAGS = "LIBS='-L=${STAGING_LIBDIR} -L=${STAGING_BASELIBDIR}' \
32 INC=-I=${STAGING_INCDIR} \
33 '-lssl -lcrypto -lz' \
34 "
35
36do_install_ptest() {
37 cp -r ${B}/t ${D}${PTEST_PATH}
38}
39
40BBCLASSEXTEND = "native"
41
42FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
43
44RDEPENDS_${PN}-ptest = " perl"