diff options
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-dns-perl_1.34.bb')
-rw-r--r-- | meta-perl/recipes-perl/libnet/libnet-dns-perl_1.34.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.34.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.34.bb new file mode 100644 index 000000000..69afe6eef --- /dev/null +++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.34.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | DESCRIPTION = "This package contains the DNS.pm module with friends." | ||
2 | HOMEPAGE = "http://www.net-dns.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "MIT" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=de95b6a896d5f861d724ea854d316a0b" | ||
7 | |||
8 | DEPENDS += "perl" | ||
9 | |||
10 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[sha256sum] = "de756e3fb6addbd32beafc869c4dd1c6a0b3783c5ef56dbefc6809443a4b1d15" | ||
13 | |||
14 | UPSTREAM_CHECK_REGEX = "Net\-DNS\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" | ||
15 | |||
16 | S = "${WORKDIR}/Net-DNS-${PV}" | ||
17 | |||
18 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" | ||
19 | |||
20 | inherit cpan ptest-perl | ||
21 | |||
22 | RDEPENDS:${PN} = " \ | ||
23 | libdigest-hmac-perl \ | ||
24 | perl-module-base \ | ||
25 | perl-module-constant \ | ||
26 | perl-module-digest-md5 \ | ||
27 | perl-module-digest-sha \ | ||
28 | perl-module-file-spec \ | ||
29 | perl-module-integer \ | ||
30 | perl-module-io-file \ | ||
31 | perl-module-io-select \ | ||
32 | perl-module-io-socket \ | ||
33 | perl-module-io-socket-ip \ | ||
34 | perl-module-mime-base64 \ | ||
35 | perl-module-scalar-util \ | ||
36 | perl-module-test-more \ | ||
37 | perl-module-time-local \ | ||
38 | " | ||
39 | |||
40 | RRECOMMENDS:${PN} += " \ | ||
41 | libnet-dns-sec-perl \ | ||
42 | " | ||
43 | |||
44 | RDEPENDS:${PN}-ptest += " \ | ||
45 | perl-module-encode \ | ||
46 | perl-module-encode-byte \ | ||
47 | perl-module-extutils-mm \ | ||
48 | perl-module-extutils-mm-unix \ | ||
49 | perl-module-overload \ | ||
50 | " | ||
51 | |||
52 | python __anonymous () { | ||
53 | # rather than use "find" to determine libc-*.so, | ||
54 | # statically export the known paths for glibc and musl | ||
55 | import os | ||
56 | if d.getVar('TCLIBC') == "glibc": | ||
57 | os.environ["LIBC"] = "${STAGING_BASELIBDIR}/libc.so.6" | ||
58 | elif d.getVar('TCLIBC') == "musl": | ||
59 | os.environ["LIBC"] = "${STAGING_LIBDIR}/libc.so" | ||
60 | else: | ||
61 | raise bb.parse.SkipRecipe("incompatible with %s C library" % | ||
62 | d.getVar('TCLIBC')) | ||
63 | } | ||
64 | |||
65 | BBCLASSEXTEND = "native" | ||