summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb
new file mode 100644
index 000000000..4e0c9c446
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb
@@ -0,0 +1,66 @@
1DESCRIPTION = "This package contains the DNS.pm module with friends."
2HOMEPAGE = "http://www.net-dns.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5
6LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=27db37b42cd1a5173a53922d67072bcb"
7
8DEPENDS += "perl"
9
10SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "67af7e5c1c339f60c45c1054374bd8ee"
13SRC_URI[sha256sum] = "52ce1494fc9707fd5a60ed71db5cde727157b7f2363787d730d4d1bd9800a9d3"
14
15UPSTREAM_CHECK_REGEX = "Net\-DNS\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
16
17S = "${WORKDIR}/Net-DNS-${PV}"
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21inherit cpan ptest-perl
22
23RDEPENDS_${PN} = " \
24 libdigest-hmac-perl \
25 perl-module-base \
26 perl-module-constant \
27 perl-module-digest-md5 \
28 perl-module-digest-sha \
29 perl-module-file-spec \
30 perl-module-integer \
31 perl-module-io-file \
32 perl-module-io-select \
33 perl-module-io-socket \
34 perl-module-io-socket-ip \
35 perl-module-mime-base64 \
36 perl-module-scalar-util \
37 perl-module-test-more \
38 perl-module-time-local \
39"
40
41RRECOMMENDS_${PN} += " \
42 libnet-dns-sec-perl \
43"
44
45RDEPENDS_${PN}-ptest += " \
46 perl-module-encode \
47 perl-module-encode-byte \
48 perl-module-extutils-mm \
49 perl-module-extutils-mm-unix \
50 perl-module-overload \
51"
52
53python __anonymous () {
54 # rather than use "find" to determine libc-*.so,
55 # statically export the known paths for glibc and musl
56 import os
57 if d.getVar('TCLIBC') == "glibc":
58 os.environ["LIBC"] = "${STAGING_BASELIBDIR}/libc.so.6"
59 elif d.getVar('TCLIBC') == "musl":
60 os.environ["LIBC"] = "${STAGING_LIBDIR}/libc.so"
61 else:
62 raise bb.parse.SkipRecipe("incompatible with %s C library" %
63 d.getVar('TCLIBC'))
64}
65
66BBCLASSEXTEND = "native"