summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb')
-rw-r--r--meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb b/meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb
new file mode 100644
index 000000000..fd51c16ac
--- /dev/null
+++ b/meta-perl/recipes-perl/libmime/libmime-types-perl_2.13.bb
@@ -0,0 +1,26 @@
1SUMMARY = "MIME::Types - Definition of MIME types"
2DESCRIPTION = "MIME types are used in MIME compliant lines, for instance \
3as part of e-mail and HTTP traffic, to indicate the type of content which \
4is transmitted. Sometimes real knowledge about a mime-type is need.\
5\n\
6This module maintains a set of MIME::Type objects, which each describe \
7one known mime type."
8HOMEPAGE = "http://search.cpan.org/~markov/MIME-Types-${PV}"
9SECTION = "libraries"
10
11LICENSE = "Artistic-1.0|GPLv1+"
12LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
13
14SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MIME-Types-${PV}.tar.gz \
15 file://run-ptest \
16 "
17SRC_URI[md5sum] = "f2892ae9e6ea660a58746699c3924817"
18SRC_URI[sha256sum] = "99c3376357bbe22cc8b6c78f560aa18d81621287695cd629008a6c4e66b77bf8"
19
20S = "${WORKDIR}/MIME-Types-${PV}"
21
22inherit cpan ptest
23
24do_install_ptest () {
25 cp -r ${B}/t ${D}${PTEST_PATH}
26}