summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb')
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb b/meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb
new file mode 100644
index 000000000..8d4aec709
--- /dev/null
+++ b/meta-perl/recipes-perl/libio/libio-compress-perl_2.204.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Perl interface to allow reading and writing of compressed data."
2DESCRIPTION = "This distribution provides a Perl interface to allow reading \
3and writing of compressed data created with the zlib and bzip2. \
4\
5IO-Compress supports reading and writing of the following compressed data \
6formats \
7 * bzip2 \
8 * RFC 1950 \
9 * RFC 1951 \
10 * RFC 1952 (i.e. gzip) \
11 * zip \
12"
13HOMEPAGE = "https://metacpan.org/release/IO-Compress"
14SECTION = "libs"
15LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
16
17LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=8e78b88f9c8ac08ae03e8ea81195ca45"
18
19SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
20
21SRC_URI[sha256sum] = "617784cb8543778681341b18fc67b74735e8b494f32f00814dd22f68ac6af018"
22
23S = "${WORKDIR}/IO-Compress-${PV}"
24
25inherit cpan
26
27RDEPENDS:${PN} += "\
28 perl-module-bytes \
29 perl-module-cwd \
30 perl-module-encode \
31 perl-module-file-glob \
32 perl-module-file-spec \
33 perl-module-posix \
34 perl-module-scalar-util \
35 perl-module-time-local \
36 perl-module-utf8 \
37 libcompress-raw-bzip2-perl \
38 libcompress-raw-zlib-perl \
39"
40
41BBCLASSEXTEND = "native"