summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb')
-rw-r--r--meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
new file mode 100644
index 000000000..9047d9f4b
--- /dev/null
+++ b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "This package contains the Parser.pm module with friends."
2
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5
6LIC_FILES_CHKSUM = "file://README;md5=b0459e4426b94753b9a9b8a15f1223b8"
7
8DEPENDS += "perl"
9
10SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTML-Parser-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "eb7505e5f626913350df9dd4a03d54a8"
13SRC_URI[sha256sum] = "ec28c7e1d9e67c45eca197077f7cdc41ead1bb4c538c7f02a3296a4bb92f608b"
14
15S = "${WORKDIR}/HTML-Parser-${PV}"
16
17EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
18
19inherit cpan
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}
25BBCLASSEXTEND = "native"