summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libextutils
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libextutils')
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-config-perl_0.007.bb24
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.07.bb38
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-helpers-perl_0.022.bb29
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-installpaths-perl_0.010.bb25
4 files changed, 116 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-config-perl_0.007.bb b/meta-perl/recipes-perl/libextutils/libextutils-config-perl_0.007.bb
new file mode 100644
index 000000000..78483b4e6
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-config-perl_0.007.bb
@@ -0,0 +1,24 @@
1SUMMARY = "ExtUtils::Config - A wrapper for perl's configuration"
2DESCRIPTION = "ExtUtils::Config is an abstraction around the %Config hash."
3SECTION = "libs"
4
5HOMEPAGE = "http://search.cpan.org/~leont/ExtUtils-Config/"
6
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b1b813683bd988732e7fd6a796bf7f47"
9
10SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/ExtUtils-Config-${PV}.tar.gz"
11SRC_URI[md5sum] = "2829c0dfa8a7e51b3f582efbee4bb128"
12SRC_URI[sha256sum] = "2c1465078b876fd16a90507092805265528c2532d4937b03547a6dbdb8ac0eef"
13
14S = "${WORKDIR}/ExtUtils-Config-${PV}"
15
16inherit cpan
17
18RDEPENDS_${PN} = " perl-module-extutils-makemaker \
19 perl-module-data-dumper \
20 perl-module-test-more \
21 perl-module-file-temp \
22"
23
24BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.07.bb b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.07.bb
new file mode 100644
index 000000000..47e090405
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.07.bb
@@ -0,0 +1,38 @@
1SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/ExtUtils-CppGuess-${PV}.tar.gz"
15SRC_URI[md5sum] = "350dd7c661189ea770d6c9354ebbc6c2"
16SRC_URI[sha256sum] = "1cd83ee8452351219b987c79ddb25cc25ee8c396318ba36c5211a92b5c87e7a8"
17
18S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
19
20inherit cpan_build
21
22do_install () {
23 cpan_build_do_install
24}
25
26RDEPENDS_${PN} = " libcapture-tiny-perl \
27 perl-module-scalar-util \
28 perl-module-io-file \
29 perl-module-extutils-makemaker \
30 perl-module-file-spec \
31 perl-module-exporter \
32 perl-module-carp \
33 perl-module-file-temp \
34 perl-module-lib \
35 perl-module-build \
36"
37
38BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-helpers-perl_0.022.bb b/meta-perl/recipes-perl/libextutils/libextutils-helpers-perl_0.022.bb
new file mode 100644
index 000000000..9a0234e59
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-helpers-perl_0.022.bb
@@ -0,0 +1,29 @@
1SUMMARY = "ExtUtils::Helpers - Various portability utilities for module builders"
2DESCRIPTION = "This module provides various portable helper function for module building modules."
3SECTION = "libs"
4
5HOMEPAGE = "http://search.cpan.org/~leont/ExtUtils-Helpers/"
6
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=307057ce232899f5caa8858560c7274b"
9
10SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/ExtUtils-Helpers-${PV}.tar.gz"
11SRC_URI[md5sum] = "cf4fd6f8caa6daac33b1111c9e93162b"
12SRC_URI[sha256sum] = "d3f8cf700fb3414ca1260089755cbf64041455e4b744110677b1ba5bb9a3aa95"
13
14S = "${WORKDIR}/ExtUtils-Helpers-${PV}"
15
16inherit cpan
17
18RDEPENDS_${PN} = " perl-module-file-copy \
19 perl-module-extutils-makemaker \
20 perl-module-exporter \
21 perl-module-carp \
22 perl-module-test-more \
23 perl-module-text-parsewords \
24 perl-module-load \
25 perl-module-file-temp \
26 perl-module-file-spec-functions \
27"
28
29BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-installpaths-perl_0.010.bb b/meta-perl/recipes-perl/libextutils/libextutils-installpaths-perl_0.010.bb
new file mode 100644
index 000000000..8de375d2e
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-installpaths-perl_0.010.bb
@@ -0,0 +1,25 @@
1SUMMARY = "ExtUtils::InstallPaths - Build.PL install path logic made easy"
2DESCRIPTION = "This module tries to make install path resolution as easy \
3as possible."
4SECTION = "libs"
5
6HOMEPAGE = "http://search.cpan.org/~leont/ExtUtils-InstallPaths/"
7
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=15bbcc2806d297df9e944b8955b38d82"
10
11SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/ExtUtils-InstallPaths-${PV}.tar.gz"
12SRC_URI[md5sum] = "f0b00cc6c04653588a6298fa1f16c07f"
13SRC_URI[sha256sum] = "d14cbff118e467900c2c488b55b83ef697d6eb1b8f592c0521f1d82848bf2156"
14
15S = "${WORKDIR}/ExtUtils-InstallPaths-${PV}"
16
17inherit cpan
18
19RDEPENDS_${PN} = " perl-module-extutils-makemaker \
20 perl-module-data-dumper \
21 perl-module-test-more \
22 perl-module-file-temp \
23"
24
25BBCLASSEXTEND = "native"