diff options
Diffstat (limited to 'meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.64.bb')
-rw-r--r-- | meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.64.bb | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.64.bb b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.64.bb new file mode 100644 index 000000000..468add972 --- /dev/null +++ b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.64.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | SUMMARY = "A Perl DBI driver for SQLite" | ||
2 | DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \ | ||
3 | thing in the distribution. So in order to get a fast transaction capable \ | ||
4 | RDBMS working for your perl project you simply have to install this \ | ||
5 | module, and nothing else. \ | ||
6 | " | ||
7 | HOMEPAGE = "https://metacpan.org/release/DBD-SQLite" | ||
8 | |||
9 | SECTION = "libs" | ||
10 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360" | ||
12 | |||
13 | SRC_URI = "${CPAN_MIRROR}/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \ | ||
14 | file://sqlite-perl-test.pl \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "10796495b52927eb2e1df34c86924027" | ||
18 | SRC_URI[sha256sum] = "f4ae8f7b50842305566aadd90f7bfd12a9e32b6c603a9b1c1529e73eb82aff01" | ||
19 | |||
20 | UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" | ||
21 | |||
22 | S = "${WORKDIR}/DBD-SQLite-${PV}" | ||
23 | |||
24 | DEPENDS += "libdbi-perl-native" | ||
25 | |||
26 | inherit cpan ptest-perl | ||
27 | |||
28 | RDEPENDS_${PN} += "libdbi-perl \ | ||
29 | sqlite3 \ | ||
30 | perl-module-constant \ | ||
31 | perl-module-locale \ | ||
32 | perl-module-tie-hash \ | ||
33 | " | ||
34 | |||
35 | do_install_append() { | ||
36 | if [ ${PERL_DBM_TEST} = "1" ]; then | ||
37 | install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl | ||
38 | fi | ||
39 | } | ||
40 | |||
41 | do_install_ptest() { | ||
42 | cp -r ${B}/MANIFEST ${D}${PTEST_PATH} | ||
43 | chown -R root:root ${D}${PTEST_PATH} | ||
44 | } | ||
45 | |||
46 | RDEPENDS_${PN}-ptest += " \ | ||
47 | libtest-nowarnings-perl \ | ||
48 | perl-module-lib \ | ||
49 | perl-module-encode \ | ||
50 | perl-module-file-spec \ | ||
51 | perl-module-file-spec-functions \ | ||
52 | perl-module-findbin \ | ||
53 | perl-module-test-more \ | ||
54 | " | ||
55 | |||
56 | BBCLASSEXTEND = "native" | ||