summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb')
-rw-r--r--meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
new file mode 100644
index 000000000..25e01fac0
--- /dev/null
+++ b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2020 Jens Rehsack <sno@netbsd.org>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A module to implement some of AutoConf macros in pure perl"
5DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \
6developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \
7Shell developers."
8
9HOMEPAGE= "https://metacpan.org/release/Config-AutoConf"
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13
14LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
15file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz"
18
19SRC_URI[md5sum] = "eeeab8cc93eef7dd2e2c343ecdf247b7"
20SRC_URI[sha256sum] = "304f66cc2653264c0fe127d21669e86d3d18cd72f2574d8f5131beec31a0a33e"
21RDEPENDS_${PN} += "libcapture-tiny-perl"
22RDEPENDS_${PN} += "perl-module-base"
23RDEPENDS_${PN} += "perl-module-carp"
24RDEPENDS_${PN} += "perl-module-config"
25RDEPENDS_${PN} += "perl-module-constant"
26RDEPENDS_${PN} += "perl-module-file-basename"
27RDEPENDS_${PN} += "perl-module-file-spec"
28RDEPENDS_${PN} += "perl-module-file-temp"
29RDEPENDS_${PN} += "perl-module-extutils-cbuilder"
30RDEPENDS_${PN} += "perl-module-extutils-cbuilder-platform-unix"
31RDEPENDS_${PN} += "perl-module-scalar-util"
32RDEPENDS_${PN} += "perl-module-strict"
33RDEPENDS_${PN} += "perl-module-text-parsewords"
34RDEPENDS_${PN} += "perl-module-warnings"
35RRECOMMENDS_${PN} += "libfile-slurper-perl"
36
37S = "${WORKDIR}/Config-AutoConf-${PV}"
38
39inherit cpan ptest-perl
40
41BBCLASSEXTEND = "native nativesdk"