summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb')
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
new file mode 100644
index 000000000..81c370df2
--- /dev/null
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "The *Compress::Raw::Zlib* module provides a Perl interface to the *zlib* \
2compression library (see "AUTHOR" for details about where to get *zlib*)."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
6
7MAINTAINER= "Poky <poky@yoctoproject.org>"
8HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Zlib"
9
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
11file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
12
13SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Zlib-2.096.tar.gz"
14
15SRC_URI[md5sum] = "4144ecdd901231553447998cf8035e4a"
16SRC_URI[sha256sum] = "cd4cba20c159a7748b8bc91278524a7da70573d9531fde62298609a5f1c65912"
17
18DEPENDS += "zlib"
19
20S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
21
22inherit cpan
23
24export BUILD_ZLIB="0"
25
26do_compile() {
27 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
28 cpan_do_compile
29}
30
31BBCLASSEXTEND = "native"