diff options
Diffstat (limited to 'meta-perl/README')
-rw-r--r-- | meta-perl/README | 91 |
1 files changed, 91 insertions, 0 deletions
diff --git a/meta-perl/README b/meta-perl/README new file mode 100644 index 000000000..68160a628 --- /dev/null +++ b/meta-perl/README | |||
@@ -0,0 +1,91 @@ | |||
1 | meta-perl | ||
2 | ========= | ||
3 | This layer provides commonly-used perl related recipes such as perl libraries | ||
4 | in the Comprehensive Perl Archive Network. | ||
5 | |||
6 | Contents and Help | ||
7 | ----------------- | ||
8 | |||
9 | In this section the contents of the layer is listed, along with a short | ||
10 | help for each package. | ||
11 | |||
12 | -- libdbi-perl -- | ||
13 | The DBI is a database access module for the Perl programming language. | ||
14 | It defines a set of methods, variables, and conventions that provide | ||
15 | a consistent database interface, independent of the actual database | ||
16 | being used. | ||
17 | |<- Scope of DBI ->| | ||
18 | .-. .--------------. .-------------. | ||
19 | .-------. | |---| XYZ Driver |---| XYZ Engine | | ||
20 | | Perl | | | `--------------' `-------------' | ||
21 | | script| |A| |D| .--------------. .-------------. | ||
22 | | using |--|P|--|B|---|Oracle Driver |---|Oracle Engine| | ||
23 | | DBI | |I| |I| `--------------' `-------------' | ||
24 | | API | | |... | ||
25 | |methods| | |... Other drivers | ||
26 | `-------' | |... | ||
27 | `-' | ||
28 | |||
29 | -- libdbd-sqlite-perl -- | ||
30 | DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire | ||
31 | thing in the distribution. So in order to get a fast transaction capable | ||
32 | RDBMS working for your perl project you simply have to install this | ||
33 | module, and nothing else. | ||
34 | |||
35 | usage: there is a test case to show you how it works | ||
36 | |||
37 | 1) vim local.conf: | ||
38 | ... | ||
39 | IMAGE_INSTALL_append = " libdbd-sqlite-perl" | ||
40 | PERL_DBM_TEST = "1" | ||
41 | ... | ||
42 | 2) build core-image-sato and boot the target | ||
43 | |||
44 | 3) run "sqlite-perl-test.pl" on target. This script includes five | ||
45 | operations create/insert/update/delete/select to do with a table. | ||
46 | |||
47 | More information can be found in the recipe's git log. | ||
48 | |||
49 | Dependencies | ||
50 | ------------ | ||
51 | |||
52 | This layer depends on: | ||
53 | |||
54 | URI: git://git.openembedded.org/openembedded-core | ||
55 | branch: master | ||
56 | revision: HEAD | ||
57 | prio: default | ||
58 | |||
59 | Adding the meta-perl layer to your build | ||
60 | --------------------------------------- | ||
61 | |||
62 | In order to use this layer, you need to make the build system aware of | ||
63 | it. | ||
64 | |||
65 | Assuming the meta-perl layer exists at the top-level of your | ||
66 | yocto build tree, you can add it to the build system by adding the | ||
67 | location of the meta-perl layer to bblayers.conf, along with any | ||
68 | other layers needed. e.g.: | ||
69 | |||
70 | BBLAYERS ?= " \ | ||
71 | /path/to/oe-core/meta \ | ||
72 | /path/to/layer/meta-perl \ | ||
73 | |||
74 | Maintenance | ||
75 | ----------- | ||
76 | |||
77 | Send patches / pull requests to openembedded-devel@lists.openembedded.org with | ||
78 | '[meta-perl]' in the subject. | ||
79 | |||
80 | When sending single patches, please using something like: | ||
81 | 'git send-email -M -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-perl][PATCH' | ||
82 | |||
83 | Layer maintainer: Hongxu Jia <hongxu.jia@windriver.com> | ||
84 | |||
85 | License | ||
86 | ------- | ||
87 | |||
88 | All metadata is MIT licensed unless otherwise stated. Source code included | ||
89 | in tree for individual recipes is under the LICENSE stated in each recipe | ||
90 | (.bb file) unless otherwise stated. | ||
91 | |||