summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libnvme/files/0001-mock.c-fix-checking-of-HAVE_GLIBC_IOCTL.patch41
-rw-r--r--meta-oe/recipes-support/libnvme/libnvme_1.12.bb (renamed from meta-oe/recipes-support/libnvme/libnvme_1.11.1.bb)5
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libnvme/files/0001-mock.c-fix-checking-of-HAVE_GLIBC_IOCTL.patch b/meta-oe/recipes-support/libnvme/files/0001-mock.c-fix-checking-of-HAVE_GLIBC_IOCTL.patch
new file mode 100644
index 0000000000..8734d443bb
--- /dev/null
+++ b/meta-oe/recipes-support/libnvme/files/0001-mock.c-fix-checking-of-HAVE_GLIBC_IOCTL.patch
@@ -0,0 +1,41 @@
1From 14328a9a429fd84ddd1a3ed4fb0eb9643c61fa58 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Mon, 7 Apr 2025 13:23:57 +0800
4Subject: [PATCH] mock.c: fix checking of HAVE_GLIBC_IOCTL
5
6Commit [ 0d8d0a55 build: do not include config.h globally ]
7changed to always pass -DHAVE_GLIBC_IOCTL=[0|1], and this causes
8a regression, for system without glibc ioctl, -DHAVE_GLIBC_IOCTL=0
9is passed, and causes error:
10../git/test/ioctl/mock.c:123:5: error: conflicting types for 'ioctl'; have 'int(int, long unsigned int, ...)'
11 123 | int ioctl(int fd, unsigned long request, ...)
12 | ^~~~~
13In file included from ../git/test/ioctl/mock.c:9:
14pathto/usr/include/sys/ioctl.h:115:5: note: previous declaration of 'ioctl' with type 'int(int, int, ...)'
15 115 | int ioctl (int, int, ...);
16
17Fixed by checking value of HAVE_GLIBC_IOCTL in mock.c
18
19Upstream-Status: Submitted [https://github.com/linux-nvme/libnvme/pull/985]
20
21Signed-off-by: Changqing Li <changqing.li@windriver.com>
22---
23 test/ioctl/mock.c | 2 +-
24 1 file changed, 1 insertion(+), 1 deletion(-)
25
26diff --git a/test/ioctl/mock.c b/test/ioctl/mock.c
27index 7402b45c..da3caba8 100644
28--- a/test/ioctl/mock.c
29+++ b/test/ioctl/mock.c
30@@ -118,7 +118,7 @@ void end_mock_cmds(void)
31 } \
32 })
33
34-#ifdef HAVE_GLIBC_IOCTL
35+#if defined(HAVE_GLIBC_IOCTL) && HAVE_GLIBC_IOCTL == 1
36 typedef int (*ioctl_func_t)(int, unsigned long, void *);
37 int ioctl(int fd, unsigned long request, ...)
38 #else
39--
402.34.1
41
diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.11.1.bb b/meta-oe/recipes-support/libnvme/libnvme_1.12.bb
index bf66099ddf..a80d34277f 100644
--- a/meta-oe/recipes-support/libnvme/libnvme_1.11.1.bb
+++ b/meta-oe/recipes-support/libnvme/libnvme_1.12.bb
@@ -11,9 +11,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
11 file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \ 11 file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
12 file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2" 12 file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
13DEPENDS = "json-c" 13DEPENDS = "json-c"
14SRCREV = "cec9feaeb03da8046d14bb395f592c601cf2ae5f" 14SRCREV = "5ec1f5284ecb0eda481f3d2d61236fbc5b46164f"
15 15
16SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master" 16SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master \
17 file://0001-mock.c-fix-checking-of-HAVE_GLIBC_IOCTL.patch"
17 18
18S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
19 20