summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch13
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl-ttf/use.pkg-config.for.freetype2.patch62
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/automake_foreign.patch21
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/use.pkg-config.for.freetype2.patch (renamed from meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch)13
4 files changed, 92 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch b/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch
deleted file mode 100644
index 2d5bd6d91..000000000
--- a/meta-oe/recipes-support/libsdl-ttf/files/automake_foreign.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: SDL2_ttf-2.0.14/Makefile.am
2===================================================================
3--- SDL2_ttf-2.0.14.orig/Makefile.am
4+++ SDL2_ttf-2.0.14/Makefile.am
5@@ -1,6 +1,8 @@
6 # Makefile.am for the SDL truetype font loading library and viewer
7 lib_LTLIBRARIES = libSDL2_ttf.la
8
9+AUTOMAKE_OPTIONS = foreign
10+
11 libSDL2_ttfincludedir = $(includedir)/SDL2
12 libSDL2_ttfinclude_HEADERS = \
13 SDL_ttf.h
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf/use.pkg-config.for.freetype2.patch
new file mode 100644
index 000000000..1116c34d0
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf/use.pkg-config.for.freetype2.patch
@@ -0,0 +1,62 @@
1From 8cf318197eea91bec6057308befbb29426d69014 Mon Sep 17 00:00:00 2001
2From: Richard Purdie <richard.purdie@linuxfoundation.org>
3Date: Thu, 22 May 2014 10:59:33 +0100
4Subject: [PATCH] freetype-config was removed from oe-core in
5
6commit 5870bd272b0b077d0826fb900b251884c1c05061
7
8 binconfig-disabled: Add class and use
9
10---
11 configure.in | 38 +++++---------------------------------
12 1 file changed, 5 insertions(+), 33 deletions(-)
13
14diff --git a/configure.in b/configure.in
15index 865075e..d7a5a81 100644
16--- a/configure.in
17+++ b/configure.in
18@@ -90,39 +90,11 @@ case "$host" in
19 esac
20 AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue)
21
22-dnl Check for the FreeType 2 library
23-dnl
24-dnl Get the cflags and libraries from the freetype-config script
25-dnl
26-AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
27-installed (optional)],
28- freetype_prefix="$withval", freetype_prefix="")
29-AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix
30-where FREETYPE is installed (optional)],
31- freetype_exec_prefix="$withval", freetype_exec_prefix="")
32-
33-if test x$freetype_exec_prefix != x ; then
34- freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
35- if test x${FREETYPE_CONFIG+set} != xset ; then
36- FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config
37- fi
38-fi
39-if test x$freetype_prefix != x ; then
40- freetype_args="$freetype_args --prefix=$freetype_prefix"
41- if test x${FREETYPE_CONFIG+set} != xset ; then
42- FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config
43- fi
44-fi
45-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
46-no_freetype=""
47-if test "$FREETYPE_CONFIG" = "no" ; then
48- AC_MSG_ERROR([
49-*** Unable to find FreeType2 library (http://www.freetype.org/)
50-])
51-else
52- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
53- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
54-fi
55+PKG_CHECK_MODULES(FREETYPE2, freetype2,
56+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
57+ LIBS="$LIBS $FREETYPE2_LIBS",
58+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
59+)
60
61 dnl Check for SDL
62 SDL_VERSION=1.2.4
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/automake_foreign.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/automake_foreign.patch
new file mode 100644
index 000000000..871e6e94e
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/automake_foreign.patch
@@ -0,0 +1,21 @@
1From f9c4ad3a171d676e3818b8f6897f325ccf0b2203 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 9 May 2017 00:57:10 -0700
4
5---
6 Makefile.am | 2 ++
7 1 file changed, 2 insertions(+)
8
9diff --git a/Makefile.am b/Makefile.am
10index 8166d91..8e05e49 100644
11--- a/Makefile.am
12+++ b/Makefile.am
13@@ -2,6 +2,8 @@
14
15 lib_LTLIBRARIES = libSDL2_ttf.la
16
17+AUTOMAKE_OPTIONS = foreign
18+
19 libSDL2_ttfincludedir = $(includedir)/SDL2
20 libSDL2_ttfinclude_HEADERS = \
21 SDL_ttf.h
diff --git a/meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/use.pkg-config.for.freetype2.patch
index 8a11f6649..1dfbec6ed 100644
--- a/meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl2-ttf/use.pkg-config.for.freetype2.patch
@@ -1,13 +1,18 @@
1freetype-config was removed from oe-core in 1From e6d2c0e130811c15b5f5cc10221fae182cb8609e Mon Sep 17 00:00:00 2001
2From: Richard Purdie <richard.purdie@linuxfoundation.org>
3Date: Thu, 22 May 2014 10:59:33 +0100
4Subject: [PATCH] freetype-config was removed from oe-core in
2 5
3commit 5870bd272b0b077d0826fb900b251884c1c05061 6commit 5870bd272b0b077d0826fb900b251884c1c05061
4Author: Richard Purdie <richard.purdie@linuxfoundation.org>
5Date: Thu May 22 10:59:33 2014 +0100
6 7
7 binconfig-disabled: Add class and use 8 binconfig-disabled: Add class and use
8 9
10---
11 configure.in | 38 +++++---------------------------------
12 1 file changed, 5 insertions(+), 33 deletions(-)
13
9diff --git a/configure.in b/configure.in 14diff --git a/configure.in b/configure.in
10index 408e8d6..5f9e730 100644 15index 9b36e15..f300cae 100644
11--- a/configure.in 16--- a/configure.in
12+++ b/configure.in 17+++ b/configure.in
13@@ -86,39 +86,11 @@ case "$host" in 18@@ -86,39 +86,11 @@ case "$host" in