summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch18
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb1
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
new file mode 100644
index 000000000..8fe9f3e70
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
@@ -0,0 +1,18 @@
1Use CMAKE_INSTALL_LIBDIR instead of hardcoding lib path
2
3Helps build on platforms where libpaths are not lib/ but say lib64/
4
5Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8--- a/src/CMakeLists.txt
9+++ b/src/CMakeLists.txt
10@@ -182,7 +182,7 @@ if(NOT FLB_WITHOUT_SHARED_LIB)
11 PROPERTIES OUTPUT_NAME fluent-bit)
12
13 # Library install routines
14- install(TARGETS fluent-bit-shared LIBRARY DESTINATION lib)
15+ install(TARGETS fluent-bit-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
16 endif()
17
18 # Static Library
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
index e50aa71a9..27b910b8b 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
@@ -4,6 +4,7 @@ BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4 4
5SRC_URI = "http://fluentbit.io/releases/0.12/fluent-bit-${PV}.tar.gz \ 5SRC_URI = "http://fluentbit.io/releases/0.12/fluent-bit-${PV}.tar.gz \
6 file://jemalloc.patch \ 6 file://jemalloc.patch \
7 file://cmake_multilib.patch \
7 " 8 "
8SRC_URI[md5sum] = "7c8708312ac9122faacf9e2a4751eb34" 9SRC_URI[md5sum] = "7c8708312ac9122faacf9e2a4751eb34"
9SRC_URI[sha256sum] = "23a81087edf0e2c6f2d49411c6a82308afc5224f67bbaa45729c057af62e9241" 10SRC_URI[sha256sum] = "23a81087edf0e2c6f2d49411c6a82308afc5224f67bbaa45729c057af62e9241"