summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch8
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch19
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch15
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch13
4 files changed, 24 insertions, 31 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch b/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
index 2ac9c0be0..5d481f232 100644
--- a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch
@@ -4,9 +4,11 @@ Upstream-Status: Pending
4 4
5Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com> 5Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com>
6--- 6---
7--- a/lib/gprocess.c 7Index: syslog-ng-3.8.1/lib/gprocess.c
8+++ b/lib/gprocess.c 8===================================================================
9@@ -1421,6 +1421,18 @@ 9--- syslog-ng-3.8.1.orig/lib/gprocess.c
10+++ syslog-ng-3.8.1/lib/gprocess.c
11@@ -1432,6 +1432,18 @@ g_process_startup_ok(void)
10 void 12 void
11 g_process_finish(void) 13 g_process_finish(void)
12 { 14 {
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
index cc8d11044..c172e4e74 100644
--- a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
@@ -10,13 +10,13 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
10 configure.ac | 17 +++++++++++------ 10 configure.ac | 17 +++++++++++------
11 1 file changed, 11 insertions(+), 6 deletions(-) 11 1 file changed, 11 insertions(+), 6 deletions(-)
12 12
13diff --git a/configure.ac b/configure.ac 13Index: syslog-ng-3.8.1/configure.ac
14index 474e094..cedca54 100644 14===================================================================
15--- a/configure.ac 15--- syslog-ng-3.8.1.orig/configure.ac
16+++ b/configure.ac 16+++ syslog-ng-3.8.1/configure.ac
17@@ -120,6 +120,9 @@ AC_ARG_ENABLE(memtrace, 17@@ -147,6 +147,9 @@ AC_ARG_ENABLE(gprof,
18 AC_ARG_ENABLE(ssl, 18 AC_ARG_ENABLE(memtrace,
19 [ --enable-ssl Enable SSL support.],,enable_ssl="auto") 19 [ --enable-memtrace Enable alternative leak debugging code.])
20 20
21+AC_ARG_ENABLE(thread-tls, 21+AC_ARG_ENABLE(thread-tls,
22+ [ --enable-thread-tls Enable Thread Transport Layer Security support.],,enable_thread_tls="no") 22+ [ --enable-thread-tls Enable Thread Transport Layer Security support.],,enable_thread_tls="no")
@@ -24,7 +24,7 @@ index 474e094..cedca54 100644
24 AC_ARG_ENABLE(dynamic-linking, 24 AC_ARG_ENABLE(dynamic-linking,
25 [ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto") 25 [ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto")
26 26
27@@ -381,12 +384,14 @@ dnl *************************************************************************** 27@@ -486,12 +489,14 @@ dnl ************************************
28 dnl Is the __thread keyword available? 28 dnl Is the __thread keyword available?
29 dnl *************************************************************************** 29 dnl ***************************************************************************
30 30
@@ -45,6 +45,3 @@ index 474e094..cedca54 100644
45 45
46 dnl *************************************************************************** 46 dnl ***************************************************************************
47 dnl How to do static linking? 47 dnl How to do static linking?
48--
491.9.1
50
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
index 755803c21..553f4a517 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
@@ -10,11 +10,11 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
10 configure.ac | 27 +++++++++++++++++---------- 10 configure.ac | 27 +++++++++++++++++----------
11 1 files changed, 17 insertions(+), 10 deletions(-) 11 1 files changed, 17 insertions(+), 10 deletions(-)
12 12
13diff --git a/configure.ac b/configure.ac 13Index: syslog-ng-3.8.1/configure.ac
14index b1e18b4..8e13025 100644 14===================================================================
15--- a/configure.ac 15--- syslog-ng-3.8.1.orig/configure.ac
16+++ b/configure.ac 16+++ syslog-ng-3.8.1/configure.ac
17@@ -73,6 +73,9 @@ AC_CONFIG_HEADERS(config.h) 17@@ -104,6 +104,9 @@ AC_CONFIG_HEADERS(config.h)
18 dnl *************************************************************************** 18 dnl ***************************************************************************
19 dnl Arguments 19 dnl Arguments
20 20
@@ -24,7 +24,7 @@ index b1e18b4..8e13025 100644
24 AC_ARG_WITH(libnet, 24 AC_ARG_WITH(libnet,
25 [ --with-libnet=path use path to libnet-config script], 25 [ --with-libnet=path use path to libnet-config script],
26 , 26 ,
27@@ -768,22 +771,26 @@ dnl *************************************************************************** 27@@ -893,22 +896,26 @@ dnl ************************************
28 dnl libnet headers/libraries 28 dnl libnet headers/libraries
29 dnl *************************************************************************** 29 dnl ***************************************************************************
30 AC_MSG_CHECKING(for LIBNET) 30 AC_MSG_CHECKING(for LIBNET)
@@ -61,6 +61,3 @@ index b1e18b4..8e13025 100644
61 if test "x$enable_spoof_source" = "xauto"; then 61 if test "x$enable_spoof_source" = "xauto"; then
62 AC_MSG_CHECKING(whether to enable spoof source support) 62 AC_MSG_CHECKING(whether to enable spoof source support)
63 if test "x$LIBNET_LIBS" != "x"; then 63 if test "x$LIBNET_LIBS" != "x"; then
64--
651.7.1
66
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch b/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
index faf967247..54ecce57e 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-invalid-ownership.patch
@@ -10,11 +10,11 @@ Signed-off-by: Ming Liu <ming.liu@windriver.com>
10 scl/Makefile.am | 2 +- 10 scl/Makefile.am | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-) 11 1 files changed, 1 insertions(+), 1 deletions(-)
12 12
13diff --git a/scl/Makefile.am b/scl/Makefile.am 13Index: syslog-ng-3.8.1/scl/Makefile.am
14index 57fad5d..2a29ca5 100644 14===================================================================
15--- a/scl/Makefile.am 15--- syslog-ng-3.8.1.orig/scl/Makefile.am
16+++ b/scl/Makefile.am 16+++ syslog-ng-3.8.1/scl/Makefile.am
17@@ -14,7 +14,7 @@ scl-install-data-local: 17@@ -27,7 +27,7 @@ scl-install-data-local:
18 fi; \ 18 fi; \
19 done 19 done
20 $(mkinstalldirs) $(DESTDIR)/$(scldir) 20 $(mkinstalldirs) $(DESTDIR)/$(scldir)
@@ -23,6 +23,3 @@ index 57fad5d..2a29ca5 100644
23 chmod -R u+rwX $(DESTDIR)/$(scldir) 23 chmod -R u+rwX $(DESTDIR)/$(scldir)
24 24
25 scl-uninstall-local: 25 scl-uninstall-local:
26--
271.7.1
28