summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.26.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam_1.26.bb b/meta-oe/recipes-support/libteam/libteam_1.26.bb
new file mode 100644
index 000000000..2cb9e8f3f
--- /dev/null
+++ b/meta-oe/recipes-support/libteam/libteam_1.26.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Library for controlling team network device"
2HOMEPAGE = "http://www.libteam.org/"
3SECTION = "libs/network"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS = "libnl libdaemon jansson"
9
10SRC_URI = "git://github.com/jpirko/libteam"
11SRCREV = "8c1cea00a21950089058e4e33ea1f7bf4deaddeb"
12
13SRC_URI[md5sum] = "565114d70c41bff6093d8e57be284e8a"
14SRC_URI[sha256sum] = "d65286379141db141bea33424ec0507bb0f827a0bf03d9c65004bb593e3d5545"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20FILES_${PN} = "${libdir}/libteam${SOLIBS} \
21"
22
23PACKAGES += "${PN}-dctl ${PN}-utils"
24FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \
25"
26FILES_${PN}-utils = "${bindir}/bond2team \
27 ${bindir}/teamd \
28 ${bindir}/teamdctl \
29 ${bindir}/teamnl \
30"
31
32RDEPENDS_${PN}-utils = "bash"
33