diff options
Diffstat (limited to 'meta-oe')
3 files changed, 67 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb new file mode 100644 index 000000000..1d3395f9e --- /dev/null +++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb | |||
@@ -0,0 +1 @@ | |||
include compat-wireless.inc | |||
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc new file mode 100644 index 000000000..faf1aabe6 --- /dev/null +++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "Latest wireless drivers" | ||
2 | HOMEPAGE = "http://wireless.kernel.org/en/users/Download" | ||
3 | SECTION = "kernel/modules" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
6 | RDEPENDS = "wireless-tools" | ||
7 | PR = "r0" | ||
8 | |||
9 | COMPAT_WIRELESS_VERSION = "3.5-rc5-1" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.5/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \ | ||
13 | file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \ | ||
14 | " | ||
15 | |||
16 | PV = "${COMPAT_WIRELESS_VERSION}" | ||
17 | |||
18 | S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}" | ||
19 | |||
20 | inherit module | ||
21 | |||
22 | EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}" | ||
23 | |||
24 | do_configure_append() { | ||
25 | sed -i "s#@./scripts/update-initramfs## " Makefile | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules | ||
30 | } | ||
31 | |||
32 | SRC_URI[md5sum] = "5d26bb5fd830ba67e920e0e4b2cff284" | ||
33 | SRC_URI[sha256sum] = "f77ec3afd7c8fb1d9583cb5c82cdc683816c7fc43cebebc1f0f029d172fcce9a" | ||
diff --git a/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch b/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch new file mode 100644 index 000000000..3a51266d0 --- /dev/null +++ b/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From fb323acc0b01bcf1ecafb9330c4fbb41cf942139 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> | ||
3 | Date: Wed, 18 Jul 2012 01:01:52 +0200 | ||
4 | Subject: [PATCH] ath5k: fix compilation without CONFIG_PCI | ||
5 | |||
6 | Without that fix we have: | ||
7 | [...]/drivers/net/wireless/ath/ath5k/led.c: In function 'ath5k_init_leds': | ||
8 | [...]/drivers/net/wireless/ath/ath5k/led.c:179:2: error: implicit declaration of function 'pci_match_id' [-Werror=implicit-function-declaration] | ||
9 | When CONFIG_PCI is not set. | ||
10 | |||
11 | Upstream-Status: Pending: Not submitted yet. | ||
12 | |||
13 | Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> | ||
14 | --- | ||
15 | drivers/net/wireless/ath/ath5k/led.c | 2 +- | ||
16 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
17 | |||
18 | diff --git a/drivers/net/wireless/ath/ath5k/led.c b/drivers/net/wireless/ath/ath5k/led.c | ||
19 | index c044476..a4de133 100644 | ||
20 | --- a/drivers/net/wireless/ath/ath5k/led.c | ||
21 | +++ b/drivers/net/wireless/ath/ath5k/led.c | ||
22 | @@ -173,7 +173,7 @@ int __devinit ath5k_init_leds(struct ath5k_hw *ah) | ||
23 | if (!ah->pdev) | ||
24 | return 0; | ||
25 | |||
26 | -#ifdef CONFIG_ATHEROS_AR231X | ||
27 | +#if defined(CONFIG_ATHEROS_AR231X) || !defined(CONFIG_PCI) | ||
28 | match = NULL; | ||
29 | #else | ||
30 | match = pci_match_id(&ath5k_led_devices[0], pdev); | ||
31 | -- | ||
32 | 1.7.4.1 | ||
33 | |||