summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch25
-rw-r--r--meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.0.bb35
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch b/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
new file mode 100644
index 000000000..a31bfaa74
--- /dev/null
+++ b/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
@@ -0,0 +1,25 @@
1Disable building some things we don't need
2
3Upstream-Status: Inappropriate [config]
4
5Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
6
7---
8 Makefile | 3 ++-
9 1 file changed, 2 insertions(+), 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index 33bd2d0..84262bd 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -115,7 +115,8 @@ LDFLAGS_AS = -shared -Wl,-soname,lib${MQTTLIB_AS}.so.${MAJOR_VERSION} -lpthread
16
17 all: build
18
19-build: | mkdir ${MQTTLIB_C_TARGET} ${MQTTLIB_CS_TARGET} ${MQTTLIB_A_TARGET} ${MQTTLIB_AS_TARGET} ${MQTTVERSION_TARGET} ${SYNC_SAMPLES} ${ASYNC_SAMPLES} ${SYNC_TESTS} ${SYNC_SSL_TESTS} ${ASYNC_TESTS} ${ASYNC_SSL_TESTS}
20+build: | mkdir ${MQTTLIB_C_TARGET} ${MQTTLIB_CS_TARGET} ${MQTTLIB_A_TARGET} ${MQTTLIB_AS_TARGET}
21+#${MQTTVERSION_TARGET} ${SYNC_SAMPLES} ${ASYNC_SAMPLES} ${SYNC_TESTS} ${SYNC_SSL_TESTS} ${ASYNC_TESTS} ${ASYNC_SSL_TESTS}
22
23 clean:
24 rm -rf ${blddir}/*
25--
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.0.bb b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.0.bb
new file mode 100644
index 000000000..fec380ce6
--- /dev/null
+++ b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-1.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
8 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
9 file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \
10 file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
11 file://about.html;md5=dcde438d73cf42393da9d40fabc0c9bc \
12"
13
14SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http"
15
16SRCREV = "e8d34da24ad807f5e698b327d67591fd4b4bfa7e"
17
18DEPENDS = "openssl"
19
20S = "${WORKDIR}/git"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install() {
25 install -d ${D}${libdir}
26 oe_libinstall -C build/output -so libpaho-mqtt3a ${D}${libdir}
27 oe_libinstall -C build/output -so libpaho-mqtt3as ${D}${libdir}
28 oe_libinstall -C build/output -so libpaho-mqtt3c ${D}${libdir}
29 oe_libinstall -C build/output -so libpaho-mqtt3cs ${D}${libdir}
30 install -d ${D}${includedir}
31 install -m 644 src/MQTTAsync.h ${D}${includedir}
32 install -m 644 src/MQTTClient.h ${D}${includedir}
33 install -m 644 src/MQTTClientPersistence.h ${D}${includedir}
34}
35