diff options
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb | 11 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-core/llvm/llvm3.3_3.3.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/breakpad/breakpad_svn.bb | 11 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_5.5.26.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb | 5 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.0.9.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/libopus/libopus_1.1.bb | 14 |
10 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb index ae7887d3c..9898a70c2 100644 --- a/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb +++ b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb | |||
@@ -17,3 +17,11 @@ do_install() { | |||
17 | install -d ${D}${bindir} | 17 | install -d ${D}${bindir} |
18 | install -m755 tinymembench ${D}${bindir}/ | 18 | install -m755 tinymembench ${D}${bindir}/ |
19 | } | 19 | } |
20 | |||
21 | # Fails to build with thumb-1 (qemuarm) | ||
22 | #| {standard input}: Assembler messages: | ||
23 | #| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16' | ||
24 | #| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16' | ||
25 | #| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5' | ||
26 | #| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16' | ||
27 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb index bd0572211..d98a0cb89 100644 --- a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb +++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb | |||
@@ -55,3 +55,14 @@ FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??" | |||
55 | 55 | ||
56 | RDEPENDS_${PN} += "bash" | 56 | RDEPENDS_${PN} += "bash" |
57 | RDEPENDS_${PN}-dev += "bash" | 57 | RDEPENDS_${PN}-dev += "bash" |
58 | |||
59 | # Fails to build with thumb-1 (qemuarm) | ||
60 | # gammu-1.32.0/libgammu/service/sms/gsmems.c:542:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 | ||
61 | # | } | ||
62 | # | ^ | ||
63 | # | Please submit a full bug report, | ||
64 | # | with preprocessed source if appropriate. | ||
65 | # | See <http://gcc.gnu.org/bugs.html> for instructions. | ||
66 | # | make[2]: *** [libgammu/CMakeFiles/libGammu.dir/service/sms/gsmems.o] Error 1 | ||
67 | # | make[2]: *** Waiting for unfinished jobs.... | ||
68 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb index a4709ce93..16e2a7dca 100644 --- a/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb +++ b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb | |||
@@ -36,3 +36,12 @@ NEEDED_PERL_MODULES = "\ | |||
36 | RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}" | 36 | RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}" |
37 | # The server seemed not to work with dropbear either | 37 | # The server seemed not to work with dropbear either |
38 | RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}" | 38 | RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}" |
39 | |||
40 | # Fails to build with thumb-1 (qemuarm) | ||
41 | #| {standard input}: Assembler messages: | ||
42 | #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4' | ||
43 | #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5' | ||
44 | #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6' | ||
45 | #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7' | ||
46 | #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs' | ||
47 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb b/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb index f0598a72c..60a222185 100644 --- a/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb +++ b/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb | |||
@@ -12,3 +12,11 @@ SRC_URI[sha256sum] = "68766b1e70d05a25e2f502e997a3cb3937187a3296595cf6e0977d5cd6 | |||
12 | 12 | ||
13 | PACKAGECONFIG ??= "" | 13 | PACKAGECONFIG ??= "" |
14 | PACKAGECONFIG[r600] = "--enable-experimental-targets=R600,,," | 14 | PACKAGECONFIG[r600] = "--enable-experimental-targets=R600,,," |
15 | |||
16 | # Fails to build with thumb-1 (qemuarm) | ||
17 | # | {standard input}: Assembler messages: | ||
18 | # | {standard input}:22: Error: selected processor does not support Thumb mode `stmdb sp!,{r0,r1,r2,r3,lr}' | ||
19 | # | {standard input}:31: Error: lo register required -- `ldmia sp!,{r0,r1,r2,r3,lr}' | ||
20 | # | {standard input}:32: Error: lo register required -- `ldr pc,[sp],#4' | ||
21 | # | make[3]: *** [/home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/llvm3.3/3.3-r0/llvm-3.3.build/lib/Target/ARM/Release/ARMJITInfo.o] Error 1 | ||
22 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb b/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb index fcebccfc7..7ada3a3b2 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb +++ b/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb | |||
@@ -76,3 +76,14 @@ breakpad_populate_sysroot() { | |||
76 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib | 76 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib |
77 | } | 77 | } |
78 | 78 | ||
79 | # Fails to build with thumb-1 (qemuarm) | ||
80 | #| {standard input}: Assembler messages: | ||
81 | #| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne' | ||
82 | #| {standard input}:2179: Error: Thumb does not support conditional execution | ||
83 | #| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq' | ||
84 | #| {standard input}:2181: Error: Thumb does not support conditional execution | ||
85 | #| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!' | ||
86 | #| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!' | ||
87 | #| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]' | ||
88 | #| make: *** [src/client/linux/handler/exception_handler.o] Error 1 | ||
89 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-devtools/php/php_5.5.26.bb b/meta-oe/recipes-devtools/php/php_5.5.26.bb index 1935ca140..8b64b2bd4 100644 --- a/meta-oe/recipes-devtools/php/php_5.5.26.bb +++ b/meta-oe/recipes-devtools/php/php_5.5.26.bb | |||
@@ -263,3 +263,12 @@ php_sstate_postinst() { | |||
263 | mv -f ${sysconfdir}/pear.tmp.conf ${sysconfdir}/pear.conf | 263 | mv -f ${sysconfdir}/pear.tmp.conf ${sysconfdir}/pear.conf |
264 | fi | 264 | fi |
265 | } | 265 | } |
266 | |||
267 | # Fails to build with thumb-1 (qemuarm) | ||
268 | # | {standard input}: Assembler messages: | ||
269 | # | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3' | ||
270 | # | {standard input}:3720: Error: unshifted register required -- `sub r2,r2,r0,asr#31' | ||
271 | # | {standard input}:3796: Error: selected processor does not support Thumb mode `smull r0,r2,r3,r3' | ||
272 | # | {standard input}:3797: Error: unshifted register required -- `sub r2,r2,r0,asr#31' | ||
273 | # | make: *** [ext/standard/math.lo] Error 1 | ||
274 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb index 10028a042..dc4ce9d0a 100644 --- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb +++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | |||
@@ -62,3 +62,12 @@ addtask sourceclean before do_patch after do_unpack | |||
62 | PACKAGES =+ "lib${PN}" | 62 | PACKAGES =+ "lib${PN}" |
63 | FILES_lib${PN} += "${libdir}/lib*.so" | 63 | FILES_lib${PN} += "${libdir}/lib*.so" |
64 | FILES_${PN}-dev += "${bindir}/js17-config" | 64 | FILES_${PN}-dev += "${bindir}/js17-config" |
65 | |||
66 | # Fails to build with thumb-1 (qemuarm) | ||
67 | #| {standard input}: Assembler messages: | ||
68 | #| {standard input}:2172: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r2,r1,LSR#20' | ||
69 | #| {standard input}:2173: Error: unshifted register required -- `bic r2,r2,#(1<<11)' | ||
70 | #| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)' | ||
71 | #| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300' | ||
72 | #| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52' | ||
73 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb b/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb index 58103f61b..bd2e5d4b4 100644 --- a/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb +++ b/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb | |||
@@ -19,3 +19,8 @@ SRC_URI[sha256sum] = "df2e6a0d9499afcbc4f9029c18d9d1e0dd5e8710a75e17c9b1d9a6480d | |||
19 | FILES_${PN} += "${libdir}/gegl-*/*.so" | 19 | FILES_${PN} += "${libdir}/gegl-*/*.so" |
20 | FILES_${PN}-dev += "${libdir}/gegl-*/*.la" | 20 | FILES_${PN}-dev += "${libdir}/gegl-*/*.la" |
21 | FILES_${PN}-dbg += "${libdir}/gegl-*/.debug" | 21 | FILES_${PN}-dbg += "${libdir}/gegl-*/.debug" |
22 | |||
23 | # Fails to build with thumb-1 (qemuarm) | ||
24 | # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process': | ||
25 | # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 | ||
26 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-kernel/crash/crash_7.0.9.bb b/meta-oe/recipes-kernel/crash/crash_7.0.9.bb index 8d6248109..586a0baa3 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.0.9.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.0.9.bb | |||
@@ -57,3 +57,7 @@ do_install () { | |||
57 | install -m 0644 ${S}/defs.h ${D}${includedir}/crash | 57 | install -m 0644 ${S}/defs.h ${D}${includedir}/crash |
58 | } | 58 | } |
59 | RDEPENDS_${PN} += "liblzma" | 59 | RDEPENDS_${PN} += "liblzma" |
60 | |||
61 | # Causes gcc to get stuck and eat all available memory in qemuarm builds | ||
62 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - | ||
63 | ARM_INSTRUCTION_SET = "arm" | ||
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb index 15782a023..948d4df36 100644 --- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb +++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.bb | |||
@@ -18,3 +18,17 @@ inherit autotools pkgconfig | |||
18 | 18 | ||
19 | require libopus-fpu.inc | 19 | require libopus-fpu.inc |
20 | EXTRA_OECONF = "${@get_libopus_fpu_setting(bb, d)}" | 20 | EXTRA_OECONF = "${@get_libopus_fpu_setting(bb, d)}" |
21 | |||
22 | # Fails to build with thumb-1 (qemuarm) | ||
23 | #| {standard input}: Assembler messages: | ||
24 | #| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4' | ||
25 | #| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1' | ||
26 | #| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0' | ||
27 | #| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1' | ||
28 | #| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1' | ||
29 | #| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3' | ||
30 | #| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10' | ||
31 | #| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9' | ||
32 | #| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8' | ||
33 | #| make[2]: *** [celt/celt.lo] Error 1 | ||
34 | ARM_INSTRUCTION_SET = "arm" | ||