summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch45
-rw-r--r--meta-oe/recipes-core/mm-common/mm-common_1.0.6.bb (renamed from meta-oe/recipes-core/mm-common/mm-common_1.0.4.bb)3
2 files changed, 1 insertions, 47 deletions
diff --git a/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch b/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch
deleted file mode 100644
index 4866a5fbe..000000000
--- a/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From af4069263487399be82ee53d48b1edda7f8e594e Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Mon, 4 Nov 2019 19:19:47 +0100
4Subject: [PATCH] meson.build: do not ask for python installation / version
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Even by adding python3-setuptools-native the following error is not fixed so
10just ask for python3 executable.
11
12| meson.build:9:0: ERROR: <ExternalProgram 'python3' -> ['<...>/recipe-sysroot-native/usr/bin/python3-native/python3']> is not a valid python or it is missing setuptools
13
14Upstream-Status: Inappropriate [OE specific]
15
16Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
17
18rebase for 1.0.4
19Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
20
21---
22 meson.build | 7 +------
23 1 file changed, 1 insertion(+), 6 deletions(-)
24
25diff --git a/meson.build b/meson.build
26index 8a18c36..34fd546 100644
27--- a/meson.build
28+++ b/meson.build
29@@ -7,12 +7,7 @@ project('mm-common',
30 # and meson.add_install_script(python3, ...)
31 )
32
33-python3 = import('python').find_installation()
34-python_version = python3.language_version()
35-python_version_req = '>= 3.5'
36-if not python_version.version_compare(python_version_req)
37- error('Requires Python @0@, found @1@.'.format(python_version_req, python_version))
38-endif
39+python3 = import('python3').find_python()
40
41 # Use these instead of meson.source_root() and meson.build_root().
42 # source_root() and build_root() are not useful, if this is a subproject.
43--
442.25.1
45
diff --git a/meta-oe/recipes-core/mm-common/mm-common_1.0.4.bb b/meta-oe/recipes-core/mm-common/mm-common_1.0.6.bb
index 3e99b38eb..a252a6b48 100644
--- a/meta-oe/recipes-core/mm-common/mm-common_1.0.4.bb
+++ b/meta-oe/recipes-core/mm-common/mm-common_1.0.6.bb
@@ -8,8 +8,7 @@ inherit gnomebase
8# All the recipe does is stage python and shell script, some autotools files; nothing is compiled. 8# All the recipe does is stage python and shell script, some autotools files; nothing is compiled.
9inherit allarch 9inherit allarch
10 10
11SRC_URI[archive.sha256sum] = "e954c09b4309a7ef93e13b69260acdc5738c907477eb381b78bb1e414ee6dbd8" 11SRC_URI[archive.sha256sum] = "b55c46037dbcdabc5cee3b389ea11cc3910adb68ebe883e9477847aa660862e7"
12SRC_URI += "file://0001-meson.build-do-not-ask-for-python-installation-versi.patch"
13 12
14BBCLASSEXTEND = "native nativesdk" 13BBCLASSEXTEND = "native nativesdk"
15 14